WordPress Vulnerability Hits +1 Million Using Header & Footer Plugin

Vulnerability found in WPCode – Insert Headers & & Footers WordPress plugin for the 2nd time in 2023

  • The vulnerability found in the WordPress plugin is the 2nd one discovered until this year.
  • Cross-Site Request Forgery (CSRF) Vulnerability might permit the removal of files.
  • More than 1 Million active setups of the afflicted WordPress plugin

The WPCode –– Insert Headers and Footers + Custom Code Snippets WordPress plugin, with over a million forms, was found to have a vulnerability that might enable the enemy to erase files on the server.

Caution of the Vulnerability was published on the United States Government National Vulnerability Database (NVD).

Place Headers and Footers Plugin

The WPCode plugin (previously called Insert Headers and Footers by WPBeginner) is a popular plugin that enables WordPress publishers to include code bits in the header and footer locations.

This works for publishers who require to include a Google Search Console website recognition code, CSS code, structured information, even AdSense code, practically anything that belongs in either the header or the footer of a site.

Cross-Site Request Forgery (CSRF) Vulnerability

The WPCode –– Insert headers and Footers plugin before variation 2.0.9 includes what has been determined as a Cross-Site Request Forgery (CSRF) Vulnerability.

A CSRF attack depends on fooling an end user signed up on the WordPress website into clicking a link that carries out an undesirable action.

The aggressor is essentially piggybacking on the signed-up user’s qualifications to carry out actions on the website on which the user is signed up.

When a visited WordPress user clicks a link with a destructive demand, the website must perform the market because they use an internet browser with cookies that correctly determines the user as visited.

It s the harmful action that the signed-up user unknowingly performs that the enemy is relying on.

The non-profit Open Worldwide Application Security Project (OWASP) explains a CSRF vulnerability:

Cross-Site Request Forgery (CSRF) is an attack that requires an end user to perform undesirable actions on a web application in which they’ re presently validated.

With a little assistance of social engineering (such as sending out a link by means of e-mail or chat), an enemy might deceive the users of a web application into performing actions of the enemy’ s picking.

If the victim is a typical user, an effective CSRF attack can require the user to carry out state altering demands like moving funds, altering their e-mail address, etc.

If the victim is an administrative account, CSRF can jeopardize the whole web application.”

The Typical Weakness Enumeration (site, which is sponsored by the United States Department of Homeland Security, provides a meaning of this sort of CSRF:

The web application does not, or can not, adequately confirm whether a well-formed, legitimate, constant demand was deliberately offered by the user who sent the demand.

When a web server is developed to get a demand from a customer with no system for confirming that it was deliberately sent out, then it may be possible for an assailant to deceive a customer into making an unintended demand to the web server which will be dealt with as a genuine demand.

This can be done by means of a URL, image load, XMLHttpRequest, and so on and can lead to direct exposure of information or unintentional code execution.”

In this case, the undesirable actions are restricted to erasing log files.

The National Vulnerability Database released information on the Vulnerability:

The WPCode WordPress plugin prior to 2.0.9 has a problematic CSRF when erasing log, and does not make sure that the file to be erased is inside the anticipated folder.

This might enable enemies to make users with the wpcode_activate_snippets ability erase approximate log files on the server, consisting of beyond the blog site folders.”

The WPScan site(owned by Automattic) released evidence of the Vulnerability principle.

Evidence of an idea, in this context, is code that confirms and shows that a vulnerability can work.

This is the evidence of the idea:

"Make a logged in user with the wpcode_activate_snippets capability open the URL below    https://example.com/wp-admin/admin.php?page=wpcode-tools&view=logs&wpcode_action=delete_log&log=../../delete-me.log    This will make them delete the ~/wp-content/delete-me.log"

2nd Vulnerability for 2023

This is the 2nd Vulnerability found in 2023 for the WPCode Insert Headers and Footers plugin.

Another vulnerability was found in February 2023, impacting variations 2.0.6 or less, which the Wordfence WordPress security business referred to as a Missing Authorization to Sensitive Key Disclosure/Update.”

According to the NVD vulnerability report, the Vulnerability likewise impacted variations of approximately 2.0.7.

The NVD alerted of the earlier Vulnerability:

The WPCode WordPress plugin prior to 2.0.7 does not have sufficient opportunity checks in location for a number of AJAX actions, just examining the nonce.

This might result in enabling any verified user who can modify posts to call the endpoints connected to WPCode Library authentication (such as upgrade and erase the auth secret).”

WPCode Issued a Security Patch

The Changelog for the WPCode –– Insert Headers and Footers WordPress plugin correctly states that they covered a security problem.

A changelog notation for variation upgrade 2.0.9 states:

Fix: Security solidifying for erasing logs.”

The changelog notation is essential since it signals users of the plugin the contents of the promotion and enables them to decide whether to continue with the promotion or wait until the next one.

WPCode acted appropriately by reacting to the vulnerability discovery on a prompt basis and likewise keeping in mind the security repair in the changelog.

Suggested Actions

WPCode –– Insert headers and Footer’s plugin users are suggested to upgrade their plugin to a minimum variation of 2.0.9.

The most as much date variation of the plugin is 2.0.10.

Check out the Vulnerability at the NVD site:

CVE-2023-1624 Detail


Leave a Reply

“You're more than just a customer; you're the hero of our stories.”

Subscribe our

Weekly Posts

to receive a variety of interesting content, special promotions and exclusive discounts. Stay ahead of the game with our exclusive updates on the latest AI technology and the trend of the digital world!